Notificar incidente

Alertas de Segurança

Alerta de Vulnerabilidades - WordPress

tipo Vulnerabilidades
Sistemas afetadosWordPress versões anteriores a 5.7.1
Ecossistema Outro

Descrição

A WordPress lançou uma versão com atualizações de segurança e manutenção. Esta atualização inclui a resolução de uma vulnerabilidade de XML External Entity (XXE) que existe dentro da biblioteca media (PHP 8).[1]
Esta vulnerabilidade só pode ser explorada caso o WordPress tenha o PHP 8 e permita o upload de ficheiros.
De referir que caso o website tenha algum plugin que permita aos utilizadores efetuar o upload de ficheiros, esta vulnerabilidade pode ser explorada por utilizadores com menos privilégios.[2]

impacto

Caso esta vulnerabilidade seja explorada com sucesso, permite ao atacante o acesso a ficheiros do website, como por exemplo o wp-config.php (ficheiro de configuração do Wordpress que contém dados sensíveis) e também que o atacante possa efetuar pedidos HTTP em nome da instalação Wordpress.

Resolução

Pode fazer o download da versão 5.7.1 ou superior a partir do website do WordPress.[3]

Referências

[1] https://wordpress.org/news/2021/04/wordpress-5-7-1-security-and-maintenance-release/
[2] https://blog.sonarsource.com/wordpress-xxe-security-vulnerability/
[3] https://wordpress.org/download/releases/